博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU 1002 Sum Problem
阅读量:5013 次
发布时间:2019-06-12

本文共 836 字,大约阅读时间需要 2 分钟。

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 223816    Accepted Submission(s): 54902

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
Author
DOOM III
 
思路:
 
代码:
#include <stdio.h>
#include <stdlib.h>
int
main
()
{
    int
n
,sum
=
0
,i
;
    while
(scanf
(
"%d"
,&n
)!=EOF
)
    {
      for
(i
=
1
;i
<=n
;i
++)
      sum
=sum
+i
;
      printf
(
"%d\n\n"
,sum
);
      sum
=
0
;
      }
}

转载于:https://www.cnblogs.com/GODLIKEING/p/3290612.html

你可能感兴趣的文章
Mock InjectMocks ( @Mock 和 @InjectMocks )区别
查看>>
如何获取免版权图片资源
查看>>
MySql避免全表扫描【转】
查看>>
Storm学习笔记二
查看>>
windows 中的类似于sudo的命令(在cmd中以另一个用户的身份运行命令)
查看>>
java===单类设计模式之饿汉式与懒汉式
查看>>
BZOJ 1083: [SCOI2005]繁忙的都市
查看>>
Maven 编译
查看>>
《学习之道》第十章学习方法29还记得散步的好处嘛
查看>>
Git常用命令总结
查看>>
iOS获取设备IP地址
查看>>
JavaSE| String常用方法
查看>>
NRF51822配对绑定要点
查看>>
C语言博客作业—数据类型
查看>>
[leetcode]Count and Say
查看>>
cookie、session和token的概念入门
查看>>
保护网站页面内容+版权
查看>>
Golang模拟客户端POST表单功能文件上传
查看>>
重启进程
查看>>
js 进度条效果
查看>>